Building Xapi

From Xen
Jump to: navigation, search

What is xapi ?

Who is this document for?

  1. People wanting to compile xapi on Archlinux (I’m not talking about _running_ it, just compile it for now).

Build from source prerequisites

You will need:

  1. the normal build tools (yaourt -S base-devel, maybe more…)
  2. Xen 4.2 and blktap headers (yaourt -S xen blktap-git)
  3. the OCaml compiler (at least version 3.12.1)
  4. the OCaml package manager, OPAM

Archlinux

 $ yaourt -S base-devel ocaml opam-git xen blktap-git
 $ opam-init
 $ opam remote add xen-dev git://github.com/xapi-project/opam-repo-dev
 $ opam install -y cdrom fd-send-recv forkexecd libvhd nbd netdev oclock ounit rpc ssl stdext syslog tapctl xen-api-libs-transitional xenctrl xenstore
 $ git clone git://github.com/vbmithr/xen-api.git
 $ git checkout archlinux
 $ git pull
 $ make

Log

  • checkout branch ea-1254 from github.com:jonludlam/xen-api.git
  • Add Arch in scripts/detect_distro.sh
  • Use xenguest stubs from github.com:xapi-project/ocaml-xen-lowlevel-libs.git